Los desarrolladores del ethereum identifican una vulnerabilidad en el EIP-1559
Página principal Noticias, Hackers, ETH
Tema de actualidad
31 de Mayo de 2021

Los desarrolladores del ethereum han descubierto una vulnerabilidad en la propuesta EIP-1559 que podría provocar una congestión de la red, según ha dicho Tim Beiko, miembro de la Fundación Ethereum.

El EIP-1559 ofrece la ampliación de una parte de las comisiones de transacción y ayuda a reducir la volatilidad del precio del gas. La propuesta también permite a los usuarios "dar propina" a los mineros con el fin de acelerar la confirmación de sus transacciones.

El desarrollador Martin Holst Swende ha destacado que EIP-1559 no tiene un límite en la cantidad máxima de dichos pagos. Esto permite a un posible atacante introducir un gran número para sobrecargar la red, incluso si no dispone de dinero suficiente para pagar. Beiko ha explicado:

"Antes del EIP-1559, esto no era posible, ya que si deseas crear una transacción con un precio de gas elevado, en realidad necesitas tener la cantidad especificada de ETH. Si tu transacción está incluida en el bloque, debes pagar esta cantidad".

Los desarrolladores han solucionado la vulnerabilidad añadiendo el código que ha sido propuesto por Swende. Algunos clientes ya han implementado la solución.

EIP-1559 formará parte del hard fork London previsto para julio.

Lea también:
Por favor, describa el error
Cerrar